How to fix Spore artifacts on ATI

I have Windows Vista 64 with an ATI card and when I started playing Spore everything was working great until I reached the Creature Stage, in which I suffered massive graphical artifacts or texture corruption.

I was going crazy because it was unplayable and I thought my graphics card was faulty, but luckily I found the solution.

NOTE: This fixed the corruption in Mirror’s Edge too

To fix the problem you will have to open the Windows Registry (Regedit) and change the value of the entry for Geometry Instancing.

To do that, go to:

  • If you have Windows Vista:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\{—-adapter id—-}\0000\UMD]

  • If you have Windows XP:

[HKEY_LOCAL_MACHINE\CurrentControlSet\Control\Video \{—-adapter id—-}\0000\

And there find the entry named “GI” and change it’s binary value to “31 00”. It works better if you also change the string named “GI_DEF” to “0”.

reggisp

And that’s it, start Spore and enjoy an artifact free session.

For the record, this is what it looked like:

spore_2009-04-20_16-14-42spore_2009-04-20_16-14-26

Tags: ,

11 Responses to “How to fix Spore artifacts on ATI”

  1. […] found a way to fix this problem and posted the solution on my web page Here. For the record It happened to me with an ATI 4850 and Catalyst […]

  2. besweeet says:

    Hey man. I wanted to leave a comment on your post regarding a simple little Midnight Club 2 patch here: http://www.nicolaspeople.com/ch3rokeesblog/?p=33

    Just wanted to say THANK YOU! Glad I can play this classic game on Windows 7 x64. The game used to crash right after the first cutscene finished. Now it loads up just fine.

  3. admin says:

    You’re welcome, I’m glad that fix still can help people :)

  4. thomas says:

    Abseloutly perfect, fixed the same artifact problem in both spore, grid and severeal other race style games.

    Absoultely win.

    thanks

  5. sidereal says:

    Awesome. Thanks. I was going to jump off a cliff if one more person suggested I update my graphics drivers. Nice to find a knowledgeable and detailed fix. Now if EA would only patch their game…

  6. layla says:

    thanks so much this fix worked for me with the sims 3 and an ATI 5650

  7. Hunain says:

    Thanks you so much MAN!!!!! I’ve searched for this issue alot But nothing help out. . . . after doing ur trick, Man u r awesome! Really Thhnx alot! Work fine Dead Island on ati 5650 now:) Love it!

  8. amd nvidia benchmark…

    […]How to fix Spore artifacts on ATI « Ch3rokee’s Blog[…]…

  9. US News Gateway…

    […]How to fix Spore artifacts on ATI « Ch3rokee’s Blog[…]…

  10. Ego.T says:

    Ego.T…

    […]How to fix Spore artifacts on ATI « Ch3rokee’s Blog[…]…

  11. Marko says:

    Hey! Thank you alot! I had this problem on CS:GO and League of Legends!

    Everyone was babeling about ATI Artifacts, but I had the feeling it was something else ;)…

    Again Thanks!

    Where the heck did you find this solution?

    Cheers!

Leave a Reply